思科路由器配置电信adsl_PPPoE接入方法-深圳市盛烽网络技术有限公司
技术支持   Support
你的位置:首页 > 技术支持

思科路由器配置电信adsl_PPPoE接入方法

2014-5-13 20:21:57      点击:
案例分析:


  此案例为XX电信adsl PPPoE接入,需要使用一个普通adsl modem和一台cisco 2600路由器(双以太口),IOS 12.2(15)T,能够实现局域网共享上网。


  此案例配置共分7步:


  第一步:配置vpdn


  vpdn enable(启用路由器的虚拟专用拨号网络——vpnd)


  vpdn-group office(建立一个vpdn组,)


  request-dialin(初始化一个vpnd tunnel,建立一个请求拨入的vpdn子组,)


  protocol pppoe(vpdn子组使用pppoe建立会话隧道)






第二步: 配置路由器连接adsl modem的接口


  interface Ethernet1


  no ip address


  pppoe enable允许以太接口运行pppoe


  pppoe-client dial-pool-number 1将以太接口的pppoe拨号客户端加入拨号池1


  第三步:配置逻辑拨号接口:


  interface Dialer1


  ip address negotiated从adsl服务商动态协商得到ip地址


  ip nat outside为该接口启用NAT


  encapsulation ppp为该接口封装ppp协议


  dialer pool 1该接口使用1号拨号池进行拨号


  dialer-group 1该命令对于pppoe是意义不大的


  ppp authentication pap callin启用ppp pap验证


  ppp pap sent-username xxxxxxx password 0 yyyyyyy使用已经申请的用户名和口令


  第四步:配置内部网络接口


  interface Ethernet0(内部网络接口)


  ip address 10.1.1.1 255.255.255.0


  ip nat inside为该接口启用NAT


  第五步:配置路由器为内部网络主机提供dhcp服务


  ip dhcp excluded-address 10.1.1.1排除地址


  ip dhcp pool ABC


  import all(导入dns和wins server)


  network 10.1.1.0 255.255.255.0


  default-router 10.1.1.1


  第六步:配置NAT:


  access-list 1 permit 10.1.1.0 0.0.0.255


  ip nat inside source list 1 interface Dialer1 overload


  第七步:配置缺省路由


  ip route 0.0.0.0 0.0.0.0 Dialer1