华为路由交换机的配置命令-深圳市盛烽网络技术有限公司
技术支持   Support
你的位置:首页 > 技术支持

华为路由交换机的配置命令

2014-5-13 20:19:30      点击:
路由器基本配置命令举例  
[Quidway]sysname router_name 命名路由器(或交换机)  
[Quidway]delete 删除Flash ROM中的配置  
[Quidway]save 将配置写入Flash ROM  
[Quidway]interface serial 0 进入接口配置模式  
[Quidway]quit 退出接口模式到系统视图  
[Quidway]shutdown/undo shutdown 关闭/重启接口  
[Quidway]ip address ip_address subnet_mask 为接口配置IP地址和子网掩码  
[Quidway]display version 显示VRP版本号  
[Quidway]display current-configuration 显示系统运行配置信息  
[Quidway]display interfaces 显示接口配置信息  
[Quidway]display ip routing 显示路由表  
[Quidway]ping ip_address 测试网络连通性  
[Quidway]tracert ip_address 测试数据包从主机到目的地所经过的网关  
[Quidway]debug all 打开所有调试信息  
[Quidway]undo debug all 关闭所有调试信息  
[Quidway]info-center enable 开启调试信息输出功能  
[Quidway]info-center console dubugging 将调试信息输出到PC  
[Quidway]info-center monitor dubugging 将调试信息输出到Telnet终端或哑终端  


换机配置命令举例(大括号{}中的选项为单选项,斜体字部分为参数值  


[Quidway]super password password 修改特权模式口令  
[Quidway]sysname switch_name 命名交换机(或路  
[Quidway]interface ethernet 0/1 进入接口视图  
[Quidway]quit 退出系统视图  
[Quidway-Ethernet0/1]duplex {half|full|auto} 配置接口双工工  
[Quidway-Ethernet0/1]speed {10|100|auto} 配置接口速率  
[Quidway-Ethernet0/1]flow-control 开启流控制  
[Quidway-Ethernet0/1]mdi {across|normal|auto} 配置MDI/MDIX  
[Quidway-Ethernet0/1]shutdown/undo shutdown 关闭/重启端口  





VLAN基本配置命令(以Quidway S3026为例) [Quidway]vlan 3 创建并进入VLAN配置模式,缺省时系统将  
所有端口加入VLAN 1,这个端口既不能被创建也不能被删除。  
[Quidway]undo vlan 3 删除一个VLAN  
[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4 给VLAN增加/删除以太网接口  
[Quidway-Ethernet0/2]port access vlan 3 将本接口加入到指定VLAN id [Quidway-Ethernet0/2]port link-type {access|trunk|hybrid} 设置端口工作方式,access(缺省)不支持802.1q帧的传送,而trunk支持(用于Switch间互连),hybrid和trunk的区别在于trunk  
只允许缺省VLAN的报文发送时不打标签,而hybrid允许多个VLAN报文发送时不打标签。  


端口聚合配置命令  
[Quidway]link-aggregation ethernet 0/7 to ethernet 0/10 {ingress|both} 配置端口聚合  
Port_num1为端口聚合组的起始端口号,Port_num2为终止端口号  
ingress为接口入负荷分担方式,both为接口出负荷分担方式。  


STP基本配置命令  
[Quidway]stp {enable|disable} 开启/关闭 STP 功能,默认关闭,开启后所有端口都参与STP 计算。  
[Quidway-Ethernet0/3]stp disable 关闭指定接口上的STP功能,如某些网络不存在环路可以关闭STP。  


PPP配置命令  
[Quidway-Serial0]link-protocol ppp 封装PPP协议  
[Quidway-Serial0]ppp authentication-mode {pap|chap} 设置验证类型  
[Quidway]local-user username password {simple|cipher} password 配置用户列表  
- PAP验证配置:  
主验证方  
[Quidway]local-user username password {simple|cipher} password 配置用户列表  
[Quidway-Serial0]ppp authentication-mode pap  
被验证方  
[Quidway-Serial0]ppp pap local-user username password {simple|cipher} password  
- CHAP验证配置:  
主验证方  
[Quidway]local-user username password {simple|cipher} password 配置被验证方用户列表  
[Quidway-Serial0]ppp chap host hostname 配置本地名称  
[Quidway-Serial0]ppp authentication-mode chap  
被验证方  
[Quidway]local-user username password {simple|cipher} password 配置主验证方用户列表  
[Quidway-Serial0]ppp chap user username 配置本地名称  


MP配置命令  
[Quidway-Serial0]ppp mp 封装MP协议  
[Quidway]ppp mp user username bind virtual-template number 建立用户与虚拟模板的对应关系  
[Quidway]interface virtual-template number 配置虚拟接口模板  
[Quidway]ppp mp max-bind number 设置虚拟模板最大绑定数(1-100)  



帧中继配置命令  
[Quidway-Serial0]link-protocol fr {mfr|ietf|nonstandard} 封装帧中继协议:IETF、Cisco兼容  
[Quidway-Serial0]fr interface-type {dte|dce|nni} 配置帧中继接口类型,NNI为帧中继交换机之间的接口。若配为DCE或NNI,则须先使能fr switching。  
[Quidway-Serial0]fr lmi type {q933a|ansi|cisco-compatible} 配置LMI协议类型  
[Quidway-Serial0]fr dlci dlci_number 配置一条本地虚电路号  
[Quidway-Serial0]fr map {ip|ipx} protocol-address dlci dlci_number 建立本地DLCI到对端协议地址的映射  
[Quidway-Serial0]fr inarp [ip|ipx] [dlci_number] 配置Inverse ARP动态映射  
[Quidway]interface type number.subinterface_number 创建并进入子接口配置模式  


RIP协议配置命令  
[Quidway]display rip 显示RIP配置信息  
[Quidway]rip 启动并进入RIP配置模式  
[Quidway-rip]network {network_number|all} 在指定网络上使能RIP  
[Quidway-rip]peer ip_address 配置报文的定点传送  
[Quidway-Ethernet0]rip version {1|2 [bcast|mcast]} 指定RIP版本及传送方式  
[Quidway-Serial0]rip work 指定接口工作状态(同rip input,rip output)  
[Quidway-rip]auto-summary 配置RIP-2路由聚合  
[Quidway-Serial0]rip authentication simple password 配置RIP-2明文认证密码  
[Quidway-Serial0]rip authentication md5 key-string string 配置RIP-2 MD5密文认证密码串  
[Quidway-Serial0]rip authentication md5 type {nonstandard-compatible|usual} 指定MD5类型  
[Quidway]debugging rip packet 打开RIP调试开关  
[Quidway]info-center console 将调试信息输出到PC  


静态路由配置命令  
[Quidway]ip route ip_address subnet_mask {interface_name|gateway_address} [preference preference_value] [reject|black_bone]  
[命令说明] reject:任何去往该目的地的报文均被丢弃,通知源主机不可达。  
black_bone:任何去往该目的地的报文均被丢弃,不通知源主机。  
当只有下一跳的接口是PPP或HDLC接口才能写interface_name,如Serial0,否则只能写gateway_address(下一跳地址)。  
[命令举例] [Quidway]ip route 129.1.0.0 16 10.0.0.2  
[Quidway]ip route 129.1.0.0 255.255.0.0 10.0.0.2  
[Quidway]ip route 129.1.0.0 16 Serial2  
[Quidway]ip route 0.0.0.0 0.0.0.0 10.0.0.2 配置缺省路由。  


OSPF配置命令  
[Quidway]router id ip_address 配置Router ID  
[Quidway]ospf enable 启用OSPF协议  
[Quidway-Serial0]ospf enable area area_id 配置当前接口所属的OSPF区域
 

1.在基于IOS的交换机上设置主机名/系统名:  
switch(config)# hostname hostname  
在基于CLI的交换机上设置主机名/系统名:  
switch(enable) set system name name-string  


2.在基于IOS的交换机上设置登录口令:  
switch(config)# enable password level 1 password  
在基于CLI的交换机上设置登录口令:  
switch(enable) set password  
switch(enable) set enalbepass  


3.在基于IOS的交换机上设置远程访问:  
switch(config)# interface vlan 1  
switch(config-if)# ip address ip-address netmask  
switch(config-if)# ip default-gateway ip-address  
在基于CLI的交换机上设置远程访问:  
switch(enable) set interface sc0 ip-address netmask broadcast-address  
switch(enable) set interface sc0 vlan  
switch(enable) set ip route default gateway  


4.在基于IOS的交换机上启用和浏览CDP信息:  
switch(config-if)# cdp enable  
switch(config-if)# no cdp enable  
为了查看Cisco邻接设备的CDP通告信息:  
switch# show cdp interface [type modle/port]  
switch# show cdp neighbors [type module/port] [detail]  
在基于CLI的交换机上启用和浏览CDP信息:  
switch(enable) set cdp {enable|disable} module/port  
为了查看Cisco邻接设备的CDP通告信息:  
switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]  


5.基于IOS的交换机的端口描述:  
switch(config-if)# description description-string  
基于CLI的交换机的端口描述:  
switch(enable)set port name module/number description-string  


6.在基于IOS的交换机上设置端口速度:  
switch(config-if)# speed{10|100|auto}  
在基于CLI的交换机上设置端口速度:  
switch(enable) set port speed moudle/number {10|100|auto}  
switch(enable) set port speed moudle/number {4|16|auto}  


7.在基于IOS的交换机上设置以太网的链路模式:  
switch(config-if)# duplex {auto|full|half}  
在基于CLI的交换机上设置以太网的链路模式:  
switch(enable) set port duplex module/number {full|half}  


8.在基于IOS的交换机上配置静态VLAN:  
switch# vlan database  
switch(vlan)# vlan vlan-num name vla  


switch(vlan)# exit  
switch# configure teriminal  
switch(config)# interface interface module/number  
switch(config-if)# switchport mode access  
switch(config-if)# switchport access vlan vlan-num  
switch(config-if)# end  
在基于CLI的交换机上配置静态VLAN:  
switch(enable) set vlan vlan-num [name name]  
switch(enable) set vlan vlan-num mod-num/port-list  


9. 在基于IOS的交换机上配置VLAN中继线:  
switch(config)# interface interface mod/port  
switch(config-if)# switchport mode trunk  
switch(config-if)# switchport trunk encapsulation {isl|dotlq}  
switch(config-if)# switchport trunk allowed vlan remove vlan-list  
switch(config-if)# switchport trunk allowed vlan add vlan-list  
在基于CLI的交换机上配置VLAN中继线:  
switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]  
Vlan-range [isl|dotlq|dotl0|lane|negotiate]  


10.在基于IOS的交换机上配置VTP管理域:  
switch# vlan database  
switch(vlan)# vtp domain domain-name  
在基于CLI的交换机上配置VTP管理域:  
switch(enable) set vtp [domain domain-name]  


11.在基于IOS的交换机上配置VTP 模式:  
switch# vlan database  
switch(vlan)# vtp domain domain-name  
switch(vlan)# vtp {sever|cilent|transparent}  
switch(vlan)# vtp password password  
在基于CLI的交换机上配置VTP 模式:  
switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]  


12. 在基于IOS的交换机上配置VTP版本:  
switch# vlan database  
switch(vlan)# vtp v2-mode  
在基于CLI的交换机上配置VTP版本:  
switch(enable) set vtp v2 enable  


13. 在基于IOS的交换机上启动VTP剪裁:  
switch# vlan database  
switch(vlan)# vtp pruning  
在基于CL I 的交换机上启动VTP剪裁:  
switch(enable) set vtp pruning enable  


14.在基于IOS的交换机上配置以太信道:  
switch(config-if)# port group group-number [distribution {source|destination}]  
在基于CLI的交换机上配置以太信道:  
switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}  


15.在基于IOS的交换机上调整根路径成本:  
switch(config-if)# spanning-tree [vlan vlan-list] cost cost  
在基于CLI的交换机上调整根路径成本:  


switch(enable) set spantree portcost moudle/port cost  
switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]  


16.在基于IOS的交换机上调整端口ID:  
switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority  
在基于CLI的交换机上调整端口ID:  
switch(enable) set spantree portpri {mldule/port}priority  
switch(enable) set spantree portvlanpri {module/port}priority [vlans]  


17. 在基于IOS的交换机上修改STP时钟:  
switch(config)# spanning-tree [vlan vlan-list] hello-time seconds  
switch(config)# spanning-tree [vlan vlan-list] forward-time seconds  
` switch(config)# spanning-tree [vlan vlan-list] max-age seconds  
在基于CLI的交换机上修改STP时钟:  
switch(enable) set spantree hello interval[vlan]  
switch(enable) set spantree fwddelay delay [vlan]  
switch(enable) set spantree maxage agingtiame[vlan]  


18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:  
switch(config-if)#spanning-tree portfast  
在基于CLI的交换机端口上启用或禁用Port Fast 特征:  
switch(enable) set spantree portfast {module/port}{enable|disable}  


19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:  
switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]  
在基于CLI的交换机端口上启用或禁用UplinkFast 特征:  
switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]  


20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name  


21. 为了从一条中继链路上删除VLAN,可使用下列命令:  
switch(enable) clear trunk module/port vlan-range  


22. 用show vtp domain 显示管理域的VTP参数.  


23. 用show vtp statistics显示管理域的VTP参数.  


24. 在Catalyst交换机上定义TrBRF的命令如下:  
switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]  


25. 在Catalyst交换机上定义TrCRF的命令如下:  
switch (enable) set vlan vlan-num [name name] type trcrf  
{ring hex-ring-num|decring decimal-ring-num} parent vlan-num  


26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口:  
switch(enable) set vlan vlan-num mod-num/port-num  
27. 命令show spantree显示一个交换机端口的STP状态.  


28. 配置一个ELAN的LES和BUS,可以使用下列命令:  
ATM (config)# interface atm number.subint multioint  
ATM(config-subif)# lane serber-bus ethernet elan-name  


29. 配置LECS:  
ATM(config)# lane database database-name  
ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address  
ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address  
ATM(lane-config-databade)# name …  


30. 创建完数据库后,必须在主接口上启动LECS.命令如下:  
ATM(config)# interface atm number  
ATM(config-if)# lane config database database-name  
ATM(config-if)# lane config auto-config-atm-address  


31. 将每个LEC配置到一个不同的ATM子接口上.命令如下:  
ATM(config)# interface atm number.subint multipoint  
ATM(config)# lane client ethernet vlan-num elan-num  


32. 用show lane server 显示LES的状态.  


33. 用show lane bus显示bus的状态.  


34. 用show lane database显示LECS数据库可内容.  


35. 用show lane client显示LEC的状态.  


36. 用show module显示已安装的模块列表.  


37. 用物理接口建立与VLAN的连接:  
router# configure terminal  
router(config)# interface media module/port  
router(config-if)# description description-string  
router(config-if)# ip address ip-addr subnet-mask  
router(config-if)# no shutdown  


38. 用中继链路来建立与VLAN的连接:  
router(config)# interface module/port.subinterface  
router(config-ig)# encapsulation[isl|dotlq] vlan-number  
router(config-if)# ip address ip-address subnet-mask  


39. 用LANE 来建立与VLAN的连接:  
router(config)# interface atm module/port  
router(config-if)# no ip address  
router(config-if)# atm pvc 1 0 5 qsaal  
router(config-if)# atm pvc 2 0 16 ilni  
router(config-if)# interface atm module/port.subinterface multipoint  
router(config-if)# ip address ip-address subnet-mask  
router(config-if)# lane client ethernet elan-num  
router(config-if)# interface atm module/port.subinterface multipoint  
router(config-if)# ip address ip-address subnet-name  
router(config-if)# lane client ethernet elan-name  
router(config-if)# …  


40. 为了在路由处理器上进行动态路由配置,可以用下列IOS命令来进行:  
router(config)# ip routing  
router(config)# router ip-routing-protocol  
router(config-router)# network ip-network-number  
router(config-router)# network ip-network-number  


41. 配置默认路由:  
switch(enable) set ip route default gateway  


42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:  
router(config)# interface interface number  
router(config-if)# mls rp vlan-id vlan-id-num  


43. 在路由处理器启用MLSP:  
router(config)# mls rp ip  


44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP域中:  
router(config)# interface interface number  
router(config-if)# mls rp vtp-domain domain-name  


45. 查看指定的VTP域的信息:  
router# show mls rp vtp-domain vtp domain name  


46. 要确定RSM或路由器上的管理接口,可以在接口模式下输入下列命令:  
router(config-if)#mls rp management-interface  


47. 要检验MLS-RP的配置情况:  
router# show mls rp  


48. 检验特定接口上的MLS配置:  
router# show mls rp interface interface number  
49. 为了在MLS-SE上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:  
set mls flow [destination|destination-source|full]  


50. 为使MLS和输入访问列表可以兼容,可以在全局模式下使用下列命令:  
router(config)# mls rp ip input-acl  


51. 当某个交换机的第3层交换失效时,可在交换机的特权模式下输入下列命令:  
switch(enable) set mls enable  


52. 若想改变老化时间的值,可在特权模式下输入以下命令:  
switch(enable) set mls agingtime agingtime  


53. 设置快速老化:  
switch(enable) set mls agingtime fast fastagingtime pkt_threshold  


54. 确定那些MLS-RP和MLS-SE参与了MLS,可先显示交换机引用列表中的内容再确定:  
switch(enable) show mls include  


55. 显示MLS高速缓存记录:  
switch(enable) show mls entry  


56. 用命令show in arp显示ARP高速缓存区的内容。  


57. 要把路由器配置为HSRP备份组的成员,可以在接口配置模式下使用下面的命令:  
router(config-if)# standby group-number ip ip-address  


58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:  
router(config-if)# standy group-number preempt  


59. 访问时间和保持时间参数是可配置的:  
router(config-if)# standy group-number timers hellotime holdtime  


60. 配置HSRP跟踪:  
router(config-if)# standy group-number track type-number interface-priority  


61. 要显示HSRP路由器的状态:  
router# show standby type-number group brief  


62. 用命令show ip igmp确定当选的查询器。  


63. 启动IP组播路由选择:  
router(config)# ip muticast-routing  


64. 启动接口上的PIM:  
dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}  


65. 启动稀疏-稠密模式下的PIM:  
router# ip multicast-routing  
router# interface type number  
router# ip pim sparse-dense-mode  


66. 核实PIM的配置:  
dallasr1># show ip pim interface[type number] [count]  


67. 显示PIM邻居:  
dallasr1># show ip neighbor type number  


68. 为了配置RP的地址,命令如下:  
dallasr1># ip pim rp-address ip-address [group-access-list-number][override]  


69. 选择一个默认的RP:  
dallasr1># ip pim rp-address  
通告RP和它所服务的组范围:  
dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number  
为管理范围组通告RP的地址:  
dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1  
dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255  
设定一个RP映像代理:  
dallasr1># ip pim send-rp-discovery scope ttl  
核实组到RP的映像:  
dallasr1># show ip pim rp mapping  
dallasr1># show ip pim rp [group-name|group-address] [mapping]  


70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value设定TTL阀值:  
dallasr1>(config-if)# ip multicast ttl-threshold ttl-value  


71. 用show ip pim neighbor显示PIM邻居表。  


72. 显示组播通信路由表中的各条记录:  
dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]  


73. 要记录一个路由器接受和发送的全部IP组播包:  
dallasr1> #debug ip mpacket [detail] [access-list][group]  


74. 要在CISCO路由器上配置CGMP:  
dallasr1>(config-if)# ip cgmp  


75.配置一个组播路由器,使之加入某一个特定的组播组:  
dallasr1>(config-if)# ip igmp join-group group-address  


76. 关闭 CGMP:  
dallasr1>(config-if)# no ip cgmp  
77. 启动交换机上的CGMP:  
dallasr1>(enable) set cgmp enable  


78. 核实Catalyst交换机上CGMP的配置情况:  
catalystla1>(enable) show config  
set prompt catalystla1>  
set interface sc0 192.168.1.1 255.255.255.0  
set cgmp enable  


79. CGMP离开的设置:  
Dallas_SW(enable) set cgmp leave  


80. 在Cisco设备上修改控制端口密码:  
R1(config)# line console 0  
R1(config-line)# login  
R1(config-line)# password Lisbon  
R1(config)# enable password Lilbao  
R1(config)# login local  
R1(config)# username student password cisco  


81. 在Cisco设备上设置控制台及vty端口的会话超时:  
R1(config)# line console 0  
R1(config-line)# exec-timeout 5 10  
R1(config)# line vty 0 4  
R1(config-line)# exec-timeout 5 2  


82. 在Cisco设备上设定特权级:  
R1(config)# privilege configure level 3 username  
R1(config)# privilege configure level 3 copy run start  
R1(config)# privilege configure level 3 ping  
R1(config)# privilege configure level 3 show run  
R1(config)# enable secret level 3 cisco  


83. 使用命令privilege 可定义在该特权级下使用的命令:  
router(config)# privilege mode level level command  


84. 设定用户特权级:  
router(config)# enable secret level 3 dallas  
router(config)# enable secret san-fran  
router(config)# username student password cisco  


85. 标志设置与显示:  
R1(config)# banner motd ‘unauthorized access will be prosecuted!’  


86. 设置vty访问:  
R1(config)# access-list 1 permit 192.168.2.5  
R1(config)# line vty 0 4  
R1(config)# access-class 1 in  


87. 配置HTTP访问:  
Router3(config)# access-list 1 permit 192.168.10.7  
Router3(config)# ip http sever  
Router3(config)# ip http access-class 1  
Router3(config)# ip http authentication local  
Router3(config)# username student password cisco  


88. 要启用HTTP访问,请键入以下命令:  
switch(config)# ip http sever  


89. 在基于set命令的交换机上用setCL1启动和核实端口安全:  
switch(enable) set port security mod_num/port_num…enable mac address  
switch(enable) show port mod_num/port_num  
在基于CiscoIOS命令的交换机上启动和核实端口安全:  
switch(config-if)# port secure [mac-mac-count maximum-MAC-count]  
switch# show mac-address-table security [type module/port]  


90. 用命令access-list在标准通信量过滤表中创建一条记录:  
Router(config)# access-list access-list-number {permit|deny} source-address [source-address]  


91. 用命令access-list在扩展通信量过滤表中创建一条记录:  
Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]  


92. 对于带内路由更新,配置路由更新的最基本的命令格式是:  
R1(config-router)#distribute-list access-list-number|name in [type number]  


93. 对于带外路由更新,配置路由更新的最基本的命令格式是:  
R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number  


94. set snmp命令选项:  
set snmp community {read-only|ready-write|read-write-all}[community_string]  


95. set snmp trap 命令格式如下:  
set snmp trap {enable|disable}  
[all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]  
set snmp trap rvcr_addr rcvr_community  


96. 启用SNMP chassis 陷阱:  
Console>(enable) set snmp trap enable chassis  


97. 启用所有SNMP chassis 陷阱:  
Console>(enable) set snmp trap enable  


…………以下由about于2002年12月6日增加…………  
98. 禁用SNMP chassis 陷阱:  
Console>(enable) set snmp trap disable chassis  


99. 给SNMP陷阱接收表加一条记录:  
Console>(enable) set snmp trap 192.122.173.42 public  


100. show snmp 输出结果。  


101. 命令set snmp rmon enable 的输出结果。  


102. 显示SPAN信息:  
Consile> show span  








一些华为路由器命令:  


删除设备配置  
reset saved-configuration  


重启  
reboot  


看当前配置文件  
display current-configuration  


改设备名  
sysname  


保存配置  
save  


进入特权模式  
sysview  
华为只有2层模式 不像cisco enale之后还要conf t  


定义acl  
acl nubmere XXXX(3000以上)进入以后  
rule permit/deny IP/TCP/UDP等 source XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX(反向)  
destination XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX(反向) eq  
注意 华为默认没有deny any any  


防火墙上端口加载ACL  
[Quidway-Ethernet0/0]firewall packet-filter 3000 inbound  


防火墙上新增加用户  
local-user XXX(用户名) password simple XXX(密码)  
local-user XXX service-type ppp  


删除某条命令  
undo(类似与cisco的no)  


静态路由  
ip route-static 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX  


对vpdn用户设置acl的接口  
inte***ce Virtual-Template1  


查看路由表  
display ip routing-table  


设定telnet密码  
user-inte***ce vty 0 4  
user privilege level 3  
set authentication password simple XXX  


启动/关闭  
启动 un shut  
关闭 shut  


动态nat设置  
acl number 3000  
rule 0 permit ip source XXX.XXX.XXX.XXX  
rule 1 permit ip source XXX.XXX.XXX.XXX  
rule 2 permit ip source XXX.XXX.XXX.XXX  
inte***ce Ethernet1/0  
des cription ====To-Internet(WAN)====  
ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX  
nat outbound 3000  
ipsec policy policy1  
利用acl来做 符合acl的IP地址可以出去(注意 此处的ACL隐含了deny any any)不符合的IP地址不可以出去  


创建vlan  
[shzb-crsw-s6506-1]vlan 100  
华为vlan不支持name  
将port放入vlan  
创建了vlan后 进入vlan模式  
[shzb-crsw-s6506-1-vlan100]port GigabitEthernet 1/0/1 to GigabitEthernet 1/0/8  
表示从G1/0/1 到1/0/8放入VLAN 100  


创建trunk  
inte***ce GigabitEthernet1/0/1  
duplex full  
speed 1000  
* port link-type trunk  
* port trunk permit vlan all  
port link-aggregation group 1  
带*号的是创建trunk链路的语句  


vlan地址指定  
inte***ce Vlan-inte***ce2  
des cription server  
ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX  
vrrp vrid 2 virtual-ip XXX.XXX.XXX.XXX  
vrrp vrid 2 priority 120  
vrrp vrid 2 preempt-mode timer delay 10  
其中vrrp语句指定vrrp 类似与hsrp  
使用vrrp要注意的是华为不支持pvst  
只能一台完全是主,一台完全是备份  
在主vrrp设备上要指定  
stp instance 0 root primary  
stp TC-protection enable  
stp enable  
在从vrrp设备上要指定  
stp instance 0 root secondary  
stp TC-protection enable  
stp enable  


交换机下面绑acl  
首先进入接口模式,输入qos命令  
[shzb-crsw-s6506-1-GigabitEthernet1/0/1]qos  
在输入如下命令  
[shzb-crsw-s6506-1-qoss-GigabitEthernet1/0/1]packet-filter inbound ip-group 3000  
华为交换机只能指定inbound方向  


启用ospf  
[shzb-crsw-s6506-1]ospf 100  
[shzb-crsw-s6506-1-ospf-100]area 0  
[shzb-crsw-s6506-1-ospf-100-area-0.0.0.0]network XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX  
配置ospf重发布  
[shzb-crsw-s6506-1-ospf-100-area-0.0.0.0]quit  
[shzb-crsw-s6506-1-ospf-100]import-route static  


建立link-group(类似与cisco的channel-group)  


link-aggregation group 1 mode manual  
然后进入接口  
port link-aggregation group 1  


启用VRRP之前必须输入  
vrrp ping-enable